Browse Source

Fix #10

Make sure the correct version of seq.el is loaded in Emacs 25.1.
workspaces 0.20
Nicolas Petton 6 years ago
parent
commit
856846322e
Signed by: nico GPG Key ID: 233587A47C207910
1 changed files with 7 additions and 0 deletions
  1. +7
    -0
      jade.el

+ 7
- 0
jade.el View File

@ -35,5 +35,12 @@
(require 'jade-nodejs)
(require 'jade-scratch)
;; HACK: In Emacs 25.1, an older version of seq.el is provided, which can be
;; loaded before jade or even package.el. If this happens, the feature `seq'
;; being already provided, the correct version of seq.el won't get loaded.
(require 'seq)
(unless (fboundp 'seq-map-indexed)
(require 'seq-25))
(provide 'jade)
;;; jade.el ends here

Loading…
Cancel
Save